CySBGN Tutorial
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Introduction

CySBGN allows Cytoscape users to import, validate and export the layout of
SBGN diagrams stored in SBGN-ML format. This plug-in extends Cytoscape
features to SBGN diagrams as shown in the last section of this tutorial.

CySBGN dependencies are:
o LibSBGN allows CySBGN to read, query, save and validate SBGN-ML files.

o CySBML is necessary for the automated conversion of SBML into SBGN,
where CySBML is used to import SBML models into Cytoscape.

o SBFC stands for Systems Biology Format Converter and is also vital for
the automated generation of SBGN diagram form a SBML model. SBFC is
responsible to convert the SBML model file into a SBGN-ML file.

CySBGN is developed in Java and it is available under GNU GPL v3 license.
Further information is available on plug-in’s webpage
www.ebi.ac.uk/saezrodriguez/cysbgn/




How to download and install CySBGN

CySBGN can be downloaded and installed from its webpage or directly within
Cytoscape using Plugins Manager.

Cytoscape recommended version: Cytoscape v2.8.3
From the webpage
1. Download CySBGN from http://www.ebi.ac.uk/saezrodriguez/cysbgn/
2. Save the CySBGN-vX.X.jar in Cytoscape plugins folder. By default is:
a. Windows: “C:\Program Files\Cytoscape-v2.x.x\plugins\”
b. Mac OS: “/Applications/Cytoscape-v2.x.x/plugins/
3. Restart Cytoscape.

From Cytoscape

Within Cytoscape:
1. Go to Plugins Manager
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Installing CySBGN dependencies

The last step in CySBGN installation is to install its dependencies. CySBGN
requires CySBML to allow the automated conversion of SBML files into SBGN
diagrams.

1. The fully supported version of CySBML can be downloaded in CySBGN
webpage (http://www.ebi.ac.uk/saezrodriguez/cysbgn/) in Download
section.

2. Save the CySBML-vX.X.jar in Cytoscape plugins folder. By default is:
a. Windows: “C:\Program Files\Cytoscape-v2.x.x\plugins\”
b. Mac OS: “/Applications/Cytoscape-v2.x.x/plugins/

3. Remove sbml-reader-2.8.X-jar-with-dependencies.jar file in Cytoscape
plugins folder



How to import a SBGN diagram

After CySBGN is installed the user can import a SBGN diagram by clicking in File
-> Import -> Network (Multiple File Types) and then select the respective
SBGN-ML file.
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Note: Example SBGN-ML files can be found and downloaded in the following
link: http://sourceforge.net/projects/cysbgn/files/SBGN-ML_Example Files/




How to generate a SBGN diagram from a SBML file

CySBGN allows to automatically generate SBGN diagrams from SBML models by
making use of CySBML plug-in and SBFC converter.

Once CySBGN is fully installed (CySBGN and CySBML) the user can select a SBML
model, then CySBGN uses SBFC to convert the selected SBML file into a SBGN-ML
file.
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Note: The conversion process may take a while

After the conversion the SBGN diagram visualization is integrated with the
information made available by CySBML plug-in (e.g. information contained in
web databases about the selected specie is displayed in a right side panel by
CySBML plug-in).



BioModels Database

The user can also take advantage of BioModels database as a resource of SBML
models.

Find Terms of Use | Privacy | Cookies

Training Industry AboutUs Help site Index [ &
BioModels Home Models Submit Support About BioModels Contact us

BioModels D. -AD of A Publi Models
o~
BioModels Database is a repository of p iewed, published, models. These models are primarily from the field of systems biology, but more generally are those of biological
interest. This resource allows biologists to store, seavch and retrieve published mathematical models. In addition, models in the database can be used to generate sub-models, can be simulated online, and
can be converted between different representational formats. This resource also features programmatic access via Web Services.

All unmodified models in the database are available freely for use and distribution, to all users. This resource is and by the Bl net@ initiative. More information about BioModels
Database can be found in the Frequently Asked Questions.
Advanced Search Model of the month
(Search) November, 2012 o
Transforming growth factor B (TGF-B) T
2 . 2 ligands activate a signaling cascade with
Models published in the literature multiple cell context dependent outcomes. {
Disruption or disturbance leads to variant [
= Browse curated models clinical disorders. A mathematical model to
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The Biotechnology and Biological Sciences Research Council
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Submit a model biosclence community is equipped to help meet some of the biggest
challenges that we face as a society. We are glad to report that
BioModels Database is one of the projects which are being funded.
Please read more about this news....

URL: http://www.ebi.ac.uk/biomodels-main/

How to download SBML models from BioModels Database

1. From BioModels main webpage (the one above) type the desired model’s
name and hit Search button
a. e.g. Middleton2012_GibberellinSignalling

2. The list with the matching models is presented. To select the model click
on the model’s ID

BioModels Home Models Submit Support About BioModels Contact us

Search - Models

Query: Middleton2012_GibberellinSignalling [all]
The search returned 1 model.

(o New Search

[=11 Curated models returned:

BIOMD0000000422 (5] Middleton2012_GibberellinSignalling 22523240 2012-08-03T13:19:38+00:00

(o New Search

Computational Systems Neuroblology Group, European Bloinformatics Insfitute. : Terms of Use : ContactUs : Developed by the BioModels.net Team

Note: Obtained model list for Middleton2012_GibberellinSignalling search



3. The user can then visualise detailed information about the model or
download it in SBML format.

a. For full support of SBFC and CySBGN we recommend, whenever
possible, to download the SBML version without identifiers

BioModels Home ~ Models  Submit  Suppot  About BioModels  Contact us I s

BIOMD0000000422 - Middleton2012_GibberellinSignalling

Download SBML | 'Other formats (auto-generated) = | Actions | Send feedback
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SBML L2 V3 (aut 4 “ Math “ Physical entities “ Parameters “ Curation ‘
SBML L2 V4 (curated) s

SBML L2 V4 (curated + Identifiers.org URLS)

Middleton AM, Ubeda-Tomés S, Griffiths J, Holman T, Hedden P, Thomas SG, Phillips AL, Holdsworth MJ, Bennett MJ, King JR, Owen MR.
. Mathematical modeling elucidates the role of transcriptional feedback in gibberellin signaling.
Publcation 1D: 22526240 Proc Natl Acad Sci U S A 2012 May:109(19)7571-6.

Centre for Plant Integrative Biology, School of Biosciences, University of Nottingham, Loughborough LE12 5RD, United Kingdom. [more!

Original Model: B/OMD0000000422.xml.origin babiolis Taxonomy Arabidopsis
set#1
Submitter: Markus R. Owen babiol:isVersionOf Gene Ontology gibberellin mediated signaling pathway

Submission ID: MODEL 1206190000
Submission Date: 19 Jun 2012 11:44:15 UTC
Last Modification Date: 03 Aug 2012 13:19:38 UTC

Creation Date: 20 Jul 2012 17:39:15 UTC

Encoders: Vijayalakshmi Chelliah
Markus R. Owen

URL: http://www.ebi.ac.uk/biomodels-main/BIOMD0000000422

4. As shown in the picture above, to get the SBML model click Download
SBML and select the appropriate version of the SBML file.

5. Save the file.



How to generate SBGN diagrams from SBML models

After installing CySBGN and CySBML plug-ins correctly (check How to download
and install CySBGN section for detailed instructions) the user can complement
SBML model visualisation with an automated generated SBGN diagram of the
model.

1. Through Plugins -> CySBGN -> SBML to SBGN... the user can select a
SBML model and generate the respective SBGN diagram.
a. The conversion process may take awhile
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Note: Since we are dealing with automated generation of diagrams the layout
may need some manual correction. Here the overlapping nodes were moved to
be completely visible. SBML model link:
http://www.ebi.ac.uk/saezrodriguez/cysbgn/files/BIOMD0000000422.xml

2. Selected node information is visible in the Results Panel (right side panel)
in CySBML tab, also Data Panel (bottom panel) shows SBML and SBGN
node’s attributes.

a. Some attributes may be hidden. Click Select All Attributes (Ov])
button to visualise all the attributes



How to import the SBML models into Cytoscape

Before importing the SBML model in Cytoscape, check if CySBML plug-in is
correctly installed (check How to download and install CySBGN section for
detailed instructions in process is analogous).

1. After CySBML is installed the user can import a SBML model by clicking in

File -> Import -> Network (Multiple File Types) and then select the
respective SBML file.

o Cytoscapem Edit View Select Layout Plugins Help
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Welcome to Cytoscape 2.8.3 Right-click + drag or Control-Click + drag to ZOOM Command-Click + drag to PAN

Note: This is how Cytoscape should look like when importing the selected model
in the previous steps using CySBML. SBML model link:
http://www.ebi.ac.uk/saezrodriguez/cysbgn/files/BIOMD0000000422.xml
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How to simplify a SBGN diagram

To render the diagrams as close as possible to the original, CySBGN creates some
auxiliary nodes and edges to overlap the Cytoscape rendering restrictions (e.g.
invisible ports to allow a edge to connect with another edge). Although, this
auxiliary shapes represent some limitations to the correct operability of
Cytoscape analysis or display methods (e.g. in a shortest path algorithm the
auxiliary nodes are considered as one step as well).

To overcome this a simplification method was available allowing to remove
displaying auxiliary shapes, SBGN complex or compartments entities. The image
below shows how a user can preform the simplification of a previously imported
SBGN diagram.

1. Importa SBGN diagram.
a. Example map kinase cascade diagram (image below)

2. The user can then automatically generate a simplified version of the
diagram. Plugins -> CySBGN -> Create simplified network...

® Cytoscape File Edit View Select Layout m Help

8006 | Manage Plugins ktop (New Session)
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H (= E Q Q Q @ ﬁ I Install Plugin from File | c:ll." Search
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Note: Link for the SBGN-ML file
http://sourceforge.net/projects/cysbgn/files/SBGN-
ML _Example Files/mapk cascade.sbgn/download
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3. After the simplification process the simplified network can be seen side-
by-side with the original SBGN diagram
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4. Analysis methods or layout algorithms can be applied to the simplified
network.
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Note: After applying the yFiles hierarchical layout manual modifications were
done of obtain a better visualisation
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How to validate a SBGN-ML file

CySBGN allows users to perform a syntactic validation of SBGN-ML documents
using libSBGN. The validation function is accessible under the CySBGN menu in
the Plugins menu and runs a syntax validation of the SBGN-ML file used to
import currently selected SBGN-ML diagram.

1. The user can select the SBGN-ML to validate through Plugins -> CySBGN -
> Validate Network SBGN-ML ...

® Cytoscape File Edit View Select Layout m Help
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4

2. Any issue found with the SBGN-ML file is listed in the Data Panel (bottom
panel) in the CySBGN-Validation tab. Selecting the issue from the list will
highlight the correspondent arc or node.
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CySBGN extending Cytoscape features to SBGN diagrams

Shortest path in a metabolic pathway

A simple example of the interaction of CySBGN with other Cytoscape plug-ins is
for instance the use CytoHubba plug-in to detect the shortest path between two
metabolites in a metabolic network.

1. Install CytoHubba plug-in through Cytoscape Plugins Manger
a. Check How to download and install CySBGN for more details

2. Import a SBGN metabolic network
a. e.g.Central plant metabolism
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Note: Link for the SBGN-ML file
http://sourceforge.net/projects/cysbgn/files/SBGN-
ML _Example Files/central plant metabolism.sbgn/download

3. In this example we want to find the shortest path between Pyruvate and
Succinate
a. After checking the network attributes (Data Panel) we know that
Pyruvate node ID is glyph595 and Succinate node ID is glyph387
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4. Before running the shortest path algorithm we need first to compute
Hubba results for each node of the network. Plugins -> cytoHubba ->
Compute Hubba results
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4

5. CytoHubba will then ask the user to select the desired network and the
attribute name to store the computed results.
a. Network: Central_plant_metabolism
b. Attribute Name: example
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6. After the scores are computed we can now define the start and end nodes
in Hubba tab in the control panel as shown below.

a. Path from Pyruvate (glyph595) to Succinate (glyph387)

® Cytoscape File Edit View Select Layout Plugins Help

800

C@scag Desktog (New Session)

BPE QAaQa @ @ l%%@& D) b & seen [

Control Panel Tl
1 f: Network = VizMapper™  Editor = Filters —Hubbn-}

Network

Central_plant_metabolism
(1324 nodes and 1322 edges)

Select nodes
‘Hubba nodes

() Choose ranking method MCC

“»

Top group 10

-Particular nodes

@ Choose particular group

glyph595
glyph387

( Paste ) ( Reset )

Display options

[ Check the first-stage nodes
™ Display the shortest path
8 Display the expaneded subnetwork

2N ala

Central,

oxaloacél ate
-

Aggabac tate T

V‘ 2334

/lb\—
m.al;(e NAD
-
SN / membrane
[.2.1.2}—<)
i . \ mitochondrion
fur'r;a?’éte
FAD ]
1.35.1
\ 6.2.1.5
FAD! guei
13.5.1 -

ISOCIIflt

1114

KOZ /

—oxog t

,4
Z
12427 %
su nyl-m

' NADHLOZ

16



7. After adding the configurations click submit button to run the algorithm.
The expected result is shown below.
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Note: The SBGN layout may not be selected by default in the shortest path
network. Set SBGN visual style in VizMapper tab in the Control Panel (left side
panel).
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Network motifs discovery

Another example of CySBGN interoperability with other plug-ins is for instance
the discovery of network motifs using NetMatch Cytoscape plug-in.

1. Install NetMatch plug-in through Cytoscape Plugins Manger
a. Check How to download and install CySBGN for more details.
b. NetMatch is not verified to work with the latest versions of
Cytoscape, although it operates correctly.

2. Import a SBGN metabolic network
a. e.g. Central plant metabolism
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Newiork Nodes | Edges G e @) dihydoortate
B Central_plant_ me1324(0) 1322(0) - lz
(241l <&
1241 = —
£o) »—{1.3.3.1
6.1.1 - F;_' ‘ 7o
oxalpacgtate NADH transp
o acetyl-CoR

/‘<,,

233.1

1 < . W02 ofotate——] -
et
L-glutainate
~ —
2&!0“ tate Tt

1.137 4213

Note: Link for the SBGN-ML file
http://sourceforge.net/projects/cysbgn/files/SBGN-
ML _Example Files/central plant metabolism.sbgn/download

3. Start NetMatch by clicking in NetMatch menu under Plugins. See image
below.

® Cytoscape File Edit View Select Layout m Help

(N N&) Manage Plugins kt
Update Plugins ]
= E Q @ Q" @ ﬁ . . I Install Plugin from File L]
Control Panel o5 =
rontro afre - - - ?J' NS § Advanced Network Merge L
< VizMapper Editor |  Filters CySBGN >
Instructions:
Drag and Drop: Network Analysis >
Network Modifications | 2

® A node shape onto the network view.
® An edge shape onto the source node, then f
click on the target node.

Double-click: |
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4. Now NetMatch tab should be visible in Control Panel (left side panel).
Click Draw a Query (pencil icon) to draw the desired motif to search in
the network.

® Cytoscape File Edit View Select Layout Plugins Hel
000

Control Panel
4 Editor Filters —N—-}
I®](Z DAl
T—

Query Properties
' Draw a Query

Query:
H Central_plant_metabolism... }-éﬂ

Query Node Attributes:

[ hiddenLabel Q
Query Edge Attributes:
[ sbgn.Class Q

Network Properties |
Network:
|| Central_plant_metabolism... |4

Network Node Attributes:

[ hiddenLabel )
Network Edge Attributes:
[ sbgn.Class Q
—Graph Properties| rMotif verification
™ Labeled Sw/edg: 100
E Directed Rand n... 100
[] 1abel shuff...
| Match || Motif || Reset
Log’ Data Panel
a
Ov
ID
Welcome to Cytoscape 2.8.3 Right-click + drag or Control-Click + drag to ZOOM Con
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5. In this case (image below) we are looking for a motif that represents a
metabolite that can be converted into another using one enzyme, and the
other way around by another different enzyme. After defining the motif
click Pass Query to NetMatch button.

‘ Cytoscape

N ala

Cytoscape Desktop

Control Panel fal NG
[ < Editor Filters o I - ] i
I[e]:[ 7 RSO NetMatch Query Editor - new query*
| Query Edit [
[ Palette | Motifs |
‘Choose one:-
(B 1a b
() o
w BN )
[ Cent
~Info:
Networ mitoc!
hidd(
S
Networl
sbgn 135.1
—Graph
V' Lab /’;““"
V' Din
n Pass Query
to NetMatch
Matcl® = =
— — |Nodes: 4 Edges: 4 Paths: 0 Loops: 0

Log

6. Click Match button in the bottom part of NetMatch tab in Control Panel.
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7. At this point NetMatch should have found some matches to the motif
defined before. The matching motifs are listed in the Result Panel (right
side of the window).

® Cytoscape File Edit View Select Layout Plugins Help

8no Cytoscape Desktop (New Session)
58 aana @ @ B OAT@ IR B
800 Central_plant. hali Results Panel ul
B
Z-Phosdho-\vc Match Num... Occurrences Nodes Image

glyph353 \J =
3 4 glyph1002,

glyph1041, /

glyph840,

glyph1193 \/.

p

4 4 glyph1206,

glyph1252, —A

glyph913,

glyph637 ./
5 4 glyph1164,

glyph1107, \

glyph614,

glyph605 \./

@ox o-ace :te/.

7 4 glyph573,
glyph449,

glyph1159, .\74.\‘{
glyph1092 b 4

[_] Create a new child network.

Welcome to Cytoscape 2.8.3 Right-click + drag or Control-Click + drag to ZOOM Command-Click + drag to PAN

Note: Here is highlighted the reversible transformation of oxaloacetate to PEP
using different enzymes.
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